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1 Update information

These release notes describe changes in Perception (including GEN series firmware) V8.60.
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2 Mid and long-term support roadmap

Starting with Perception V8.00 some legacy features, mainframe and card support are no longer present. (A
Perception V7.6x maintenance version is available for critical bug fix support.)

2.1 Supported on latest Windows versions

Including all updates until June 2023:

• Windows 10 Pro 1607 and higher (64 bit only)
• Windows 11 Pro

Installation requirements:

• Dot Net Framework V4.8 (distributed with the install CD and available for download on the internet)
• Microsoft Direct3D® capable graphics card.

2.2 Downgrade

Perception V8.60 can be downgraded to the following versions.
Note: When an EtherCAT card is installed, a downgrade to any version before V8.28 must go
through version V8.28 first.

• Perception V8.5x
• Perception V8.4x
• Perception V8.3x
• Perception V8.2x
• Perception V8.1x
• Perception V8.0x
• Perception V7.6x
• Perception V7.5x
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3 Perception Versions

Version Description
Perception Standard Free

1-PERC-AD-0x Perception Advanced Paid
1-PERC-VA-0x Perception Viewer Enterprise Paid
1-PERC-E64-0x Perception Enterprise Paid

Perception supports the following application extensions:

Version Description
1-PERC-OP-EDR eDrive application (setup, live and efficiency mapping table) Paid
1-PERC-OP-STL Advanced High Voltage/High Power analysis according STL

standards
Paid

1-PERC-OP-HIA High Voltage Impulse Analysis Paid
1-PERC-OP-CSI CSI Runtime extensions (Customized Software Interfaces) Paid
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4 Known Issues

Perception
settings

Mainframe settings changed via the Fieldbus remote control are not updated in the UI.
Reconnecting to the mainframe will show the changes.

Perception
recording

When in Perception -> Settings -> Acquisition all optional storage is disabled, the
recording will not stop the normal way. It will stop after a timeout of several minutes.

Split recording
and RTFDB
functions

When using the option for split recording (in Perception go to File -> Preferences… ->
Perception -> Recordings) together with one of the RTFDB functions TimedMean(),
TimedStdDev(), NumSamplesMean() or NumSamplesStdDev(), the different parts of
the recording will remain locked until the end of the acquisition.
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5 New Features

5.1 Perception – General new features

Add hardware
settings to a
recording stored
on a mainframe

In the GHS/Perception system, each GHS mainframe contains several hardware
settings that influence how signals are measured (e.g., the range used for
measuring a signal, filter settings). Therefore, in order to know exactly how a
recording was made, it is important to have access to the hardware settings of all
the mainframes that were involved in the recording. Up until now, when a
recording was made by storing all the data directly on the internal disk of each
mainframe (as opposed to storing all or some of the data on PC), the hardware
settings of each mainframe were not available in the recording. In the new release,
it is possible to include the hardware settings of a mainframe in the recording
written to the mainframe's internal disk. In Perception, go to File → Preferences →
Perception → Recordings and check the box in front of 'Store settings in mainframe
recording'. If afterwards the recordings on each mainframe are merged into a
single recording, the hardware settings of each mainframe are then also available
in the merged recording. See also the feature 'Semi-automatic merge of mainframe
data' in these release notes for further information.

Automatic merge
of mainframe data

In the GHS/Perception system, it is possible, and sometimes necessary, to store a
recording partially or completely on the internal disc of a GHS mainframe. In this
release it has been made possible to automatically merge the different parts of a
recording into a single recording file on a PC. In Perception, go to File → Preferences
→ Perception → Recordings. In the 'Automerge of mainframe recordings' box, check
the box 'Enable automerge of recording' if an automatic merge should take place
and select when the merge should be done. Furthermore, a location for the merged
recording can be selected and optionally, the original files can be deleted after the
merge has been completed. Merging can be done as a background process while a
new recording is going on. An additional improvement in this context is that the
speed of transferring a recording from a mainframe to the PC was increased by a
factor 2.
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Release Notes

Rework of the
Spectral Display
including new
features

In Perception, the Spectral Display can be used to represent time signals in the
frequency domain (in Perception, in the menu bar or in an empty space, click the
Spectral Display icon and link it to a time domain Display). In this release, the
Spectral Display was completely reworked with the following new or updated
functionalities.

• The user can select for which signals in the linked time domain Display the
spectrum should be shown. This avoids clutter in the Spectral Display when
there are many signals in the time domain display and hence many spectra in
the Spectral Display. In the Spectral Display, right-click → Properties and in the
Trace Selection tab, add signals to or remove signals from the 'Selected
channels:' box.

• In Review while recording, it is now possible to always show the spectrum for
the newest part of the recording such that near-real-time spectra can be
shown, also when averaged spectra are specified. Although the Live view of
the Spectral Display also shows real-time spectra, it cannot show averaged
spectra. In the Spectral Display, right-click → Properties and in the Display
Setup tab, in the box 'Data shown in Review while recording', select 'Show
newest data'.

• Averaged spectra are the result of averaging individual spectra which together
cover a certain time interval. This time interval, or averaging area, is
indicated in the time domain Yt display by two cursors. Additional lines
between the two cursors indicate the time interval over which the newest
single spectrum that was added to the average is calculated. In Review mode,
moving the additional lines in the time domain Display by pushing the replay
control 'Next frame' at the bottom of the Spectral Display, adds individual
spectra one at a time to the average until the end of the averaging area is
reached. This makes it possible to see how the average changes over time
when spectra are added. In the previous version of the Spectral Display, only
the 'Next frame' button could be used. In the new release also the 'Previous
frame' button can be used to facilitate navigation through the spectra that
make up an average spectrum.

• As explained in the previous bullet, when doing spectral averaging, in the time
domain Yt display, for a single linked Spectral Display, there are two cursors
(indicating the averaging area) and two additional lines between the cursors
(the newest time interval for which a spectrum is calculated). When doing no
averaging, only the lines indicating the newest time interval are shown. When
more than one Spectral Display is linked to a single time domain Yt Display, it
is unclear which set of cursors is related to which Spectral Display. In the new
Spectral Display it is possible to choose the color of the cursors making it
easier to link a time interval to a spectrum. In the Spectral Display, right-click
→ Properties and in the Display Setup tab, in the box 'Frame cursor colors in Yt
display' and select the colors for the newest time interval (Active frame) and
the Averaging area.

• The Kaiser-Bessel window was added as a possible choice for time domain
windowing. In the Spectral Display, right-click → Properties and in the Spectral
Settings tab, in the box 'Time window', select Kaiser-Bessel from the
drop-down menu.

• Spectra can now also be displayed as A-weighted, which is useful when
spectra are related to sound signals. In the Spectral Display, right-click →
Properties and in the Grid and Scaling tab, in the box 'Y axis', select 'A-
weighted (dB)' under the header 'Grid'.

In the
Measurement
Uncertainty sheet,
support for new
hardware was
added

The measurement uncertainty (MU) of a measurement depends on the properties
of the used hardware (sensors, acquisition cards, etc.) which should be
incorporated in the MU calculations. In the Measurement Uncertainty sheet,
support was added for the T12 w-version torque sensor (but not yet for the minimal
torque value of 100Nm). Furthermore, support for the GN610B/GN611B acquisition
card was added, as well as support for burden resistors to allow for measuring both
voltages and currents with those cards. After loading the 'MU Estimation
(Basics)'sheet, the GN610B card can be selected from the drop-down menus under
'Used Acquisition Card'. When the GN610B card is selected, the current should be
measured using 'Card&HBR & CT' and from the drop-down menu with 'HBR:', the
type of burden resistor can be selected. As before, the CT can be selected from the
drop-down menu with 'CT:'. The T12 w version can be selected under 'Torque' and
the 'Sensor' in the 'Mechanical Power' part of the sheet.
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Release Notes

Allow publishing
any value on the
fieldbuses in case
of an invalid
signal

In some cases, the system cannot generate signal values. An example of such a
situation is when in auto-ranging mode the range is being adapted. In those cases,
for a short time, a signal will not be valid. When such signals are published on the
fieldbuses, Not a Number (NaN) is published. Since not all external systems can
easily handle NaN, it is now possible to select a user-defined value when a signal is
not valid. In Perception, go to Settings → Real-time Data → Publishing and under
'General settings', select 'Specific value:' and specify the value to be published in
case a signal is not valid.

Allow triggering
of signals in Live
display based on
cycles

In the Live display in Perception, signals are often not stable but 'running', just like
in an oscilloscope that is not triggered. In the new release, it is possible to trigger
signals based on cycle signals. Periodic signals related to a selected cycle signal
will then be stable in the Live display. To choose which cycle signal to use for
triggering, in the hamburger menu of the Live display (three small horizontal lines
in the top-left), choose 'Cycle trigger...' and in the roll-down menu, select the cycle
signal to be used for triggering the display. For this functionality is available in
Perception and not yet in the ePower suite.

5.2 Perception – New ePower Suite Features

Using field bus
signals, allow
easy detection if a
setup is in
steady-state

A setpoint of an eDrive setup (e.g., the efficiency for a certain torque/speed
combination), is commonly measured when a system is in steady-state. In the new
release, additional RTFDB functions can be instantiated by the ePower suite which,
for a number of relevant signals, determine the mean and standard deviation. If
those signals are published on the field buses, this allows an external automation
system to easily determine if the setup is in steady-state by looking at the standard
deviation or the ratio of the standard deviation and the mean. The user can
determine how the samples to determine this mean and standard deviation are
selected in terms of a specified number of samples or as a time interval: in the
ePower suite, go to Generic settings and in the 'Sample selection for designated
Mean/StdDev signals' area, choose how the samples should be selected. The
default selection for new ePower suite setup can be done in Perception by loading
the ePower suite, go to File → Preferences → ePower suite → Generic and in the
'Sample selection for designated Mean/StdDev signals' area, choose how the
samples should be selected.
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Release Notes

5.3 New Features for Hardware

XCP over Ethernet This command is used to synchronize command execution after timeout conditions.
This release supports the functionality of “XCP Over Ethernet – Output” which
means data from the mainframe (slave) can be read by the master via XCP. In
Perception, Real time data -> Publishing , a new column “Publish to XCP over
Ethernet” will be available to allow publishing like existing fieldbus. For generating
the A2L file, “Save A2L file as…” button is available.
The following Standard commands** are currently supported which
allows/maintains the XCP master and slave connection:

The following Data Acquisition commands are currently supported which allows
to read data from XCP slave by the XCP master:

• Static DAQ list configuration:
– GET_DAQ_CLOCK, GET_DAQ_PROCESSOR_INFO,
GET_DAQ_RESOLUTION_INFO, SET_DAQ_LIST_MODE,
SET_DAQ_LIST_MODE_SHORT, SET_DAQ_PTR, SET_DAQ_PTR_SHORT,
START_STOP_DAQ_LIST, START_STOP_DAQ_LIST_SHORT,
START_STOP_SYNC, START_STOP_SYNC_SHORT, WRITE_DAQ,
WRITE_DAQ_INTEL, WRITE_DAQ_SHORT

• Dynamic DAQ List Configuration:
– ALLOC_DAQ, ALLOC_DAQ_INTEL, ALLOC_DAQ_SHORT, ALLOC_ODT,
ALLOC_ODT_SHORT, ALLOC_ODT_ENTRY, ALLOC_ODT_ENTRY_SHORT,
FREE_DAQ

Known Limitations for 8.60 release:
1. This has been tested using CANape ONLY.
2. There are known issues with ETAS Inca and is being worked upon for next

minor releases.
3. This is NOT supported for integrated systems.
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Release Notes

Mainframe control
via EtherCAT PDO

This is the first major release which will allow mainframe control via EtherCAT PDO.
On EtherCAT, several communication protocols are available. Up until now, GHS
provided Remote Control via EtherCAT CoE (CAN over EtherCAT), but only SDO as
the supported mechanism. From this release onwards, PDO will be supported as
well.
Two new PDO objects were added: One for receiving (”Remote Control (Rx)”) and
one for transmitting Remote Control messages (”Remote Control (Tx)”). They
include the following entries: Command, Recorder, Channel, Value, and for the Tx
PDO an extra ReturnCode entry for status information.
For PDO, data is exchanged in the EtherCAT bus every cycle so a handshake
mechanism was implemented to avoid running the same command unnecessarily
every cycle. If the command entry is different, the operation is executed, otherwise
is ignored. If the user wants to run the same command (e.g. changing recorder,
channel, or value entries) then it must first switch the command entry to NoOp
(Command 0x00) and then change back to the desired command. The command
structure is the same as the previously implemented FieldBus Remote Control used
in EtherCAT SDO and CAN.
FieldBus Remote Control documentation maybe referred for more information on
the available commands and how to use them and return code description.
Known Issues:
This issue is intermittently observed during Conformance Tool Test. The impact of
this to end user is very low or no impact.
During transition from Operational to Safe Operational there can be a conflicting
deactivation of Sync Managers where one of the Sync Managers should remain
enabled. During transition from Operational to Safe Operational an Invalid Al Status
can sometimes be reported.
If issues are observed, performing a controlled system reset will help in restoring
proper functionality. This can clear temporary faults or errors caused by the
transition to SafeOp.

5.4 Improvements in Perception

Modernized the
look-and-feel of
Perception

Many of the icons and graphics were updated to give a more modern
look-and-feel and to improve usability.

Prevent large
MatLab/MDF4 export
files due to
asynchronous signals

Asynchronous signals are the results of cycle-based processing and the time
between samples is at least 0.5ms. When exporting, those signals were
resampled at a high sample rate leading to large files. In the new release,
when exporting signals from Perception to Matlab or MDF4, it is now possible
to export asynchronous signals as asynchronous signals, or resampled at a
lower user-defined sample rate leading to significantly smaller file sizes for
those formats. This option can be found in the regular export dialog (File →
Export Recording ...).

Improve how a user
can see and print the
hardware settings
from a recording

Up until now, hardware settings of a recording could be printed by loading a
recording as Active, and then selecting File → Print → Settings from file... after
which the active recording had to be loaded again. Two additional entries in
the Print sub menu to make this easier: 'Settings from active recording...' and
' Settings from current settings...' .

Report CAN signal
definition errors in
Perception

When a wrong definition of the setup of CAN channels is provided, Perception
now gives an error message such that the setup can be corrected.

Add key-mouse
combination for
temporarily grouping
of cursors

Grouping cursors means that the grouped cursors move together when
dragging one of the grouped cursors. Currently the user has the option to
group/ungroup cursors by pushing a button in the menu bar. To improve
usability it is now possible to press the Alt-key, drag one of the cursors and
the related cursors will move as a group. This works for horizontal, vertical
and slope cursors.
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Release Notes

5.5 Improvements for Hardware

No special license for
RTFDB on CAN inputs

Perception 8.50 required a special license to allow processing CAN signals in
the RTFDB. This feature is free of charge for customers within Perception
maintenance, so licensing is no longer required.

Allow for
unsigned/signed 16-bit
CAN inputs

Next to 32-bit and 64-bit signed and unsigned CAN signals, we now also allow
for 16-bit signed and unsigned CAN input signals.

Allow integrating
asynchronous samples

The IntegrateGated() function in the Real-time formula database allows
signals to be integrated over a time interval where the start of the integration
and the length of the integrated interval can be controlled from the field
buses in a flexible manner. Up until now, this function could only handle
synchronous signals to be integrated (such as instantaneous electrical power)
but not asynchronous signals which are used, for example, to describe the
instantaneous mechanical power. From this release, the IntegrateGated()
function can also handle asynchronous signals.

Additional CAN sample
rates

In previous releases, all CAN input signals to a GHS mainframe were sampled
at a rate of 100S/s. It is now possible to choose a different sample rate for
each CAN recorder. When choosing a higher sample rate, the maximum
number of allowed channels is reduced. The constraint is that the sum, over
all CAN recorders, of the product of the sample rate and the number of
channels should be lower than 100,000. Some feasible examples are as
follows:

• 1000 channels at 100S/s
• 500 channels at 200S/s
• 200 channels at 500S/s
• 100 channels at 1000S/s
• 40 channels at 2500S/s
• 25 channels at 2500S/s, and 30 channels at 500S/s, and 15 channels at
100S/s, and 75 channels at 100S/s

NOTE that due to resource limitations the GEN2tB only offers a single sample
rate of 100 S/s for CAN input signals.
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6 Improvements

6.1 Support items and requests

Averaging in Spectral
Display always Peak
hold average

SUPEPT-112 In the Perception Spectral display, the averaging was always
peak-hold rather than the selected linear or exponential. This
issue is fixed such that now the proper averaging is done.

CAN bus stopped
unexpectedly

SUPEPT-218 A problem is solved where the CAN bus stopped
unexpectedly.

Fundamental
calculation issue on
RT-FDB

SUPEPT-243 A problem with cross-board cycle signals used for doing
fundamental calculations was solved.

Change of conditional
Start/Stop time does
not work during the
recording

SUPEPT-270 In Perception it is possible to conditionally start or stop a
recording. Up until now it was possible to change the
conditions during a recording which might lead to
unexpected or undefined situations. In this release it is no
longer possible to change conditions during a recording such
that the conditions are always well-defined.

Graphical problem in
Report sheet tables in
Perception

SUPEPT-271 A problem with columns width when automatically
generating a report was solved.

User defined display
color is not
permanent stored

SUPEPT-273 User-defined colors are now stored as part of the PC settings.

New type of Peak CAN
dongle was not
accepted

SUPEPT-274 Peak provides the USB CAN dongle with different internal
chip sets. The updated Peak dongles are now also
recognized and can be used.

Switching display
mode to ReviewSweep
does show the full
recording instead
sweep

SUPEPT-278 A problem with switching between Review and ReviewSweep
in the time display was solved.

Using macro function
auto scale active
display y-axis is takes
only action on first
page of the display

SUPEPT-288,
SUPEPT-320

The macro function auto scale active display y-axis now
works on all pages of a display.

The format of the
displayed value in a
marker does not
reflect the format set
in Properties for the
marker

SUPEPT-291 A small formatting discrepancy between marker field and the
properties of a marker was solved.

Suppress overrange
drawing does not
work as expected

SUPEPT-293,
SUPEPT-296

Some related issues concerning drawing or suppressing
overrange data where solved.

Trace marker not
connected to trace
line

SUPEPT-297 A trace marker is now always connected to a trace.
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Release Notes

Loading existing
workbench ends up
with incomplete
workbench

SUPEPT-299 A problem with connecting to a mainframe specified in a
virtual workbench was solved and made more robust.

NaN in log file when
doing processing

SUPEPT-308 When using one of the FDB functions (CycleFundamental)
the output may give NaN. This problem is solved.

Load Settings menu
option doesn't load
workbench settings
completely

SUPEPT-312 A problem with incomplete loading of working bench settings
was solved.

Freeze when
duplicating signals for
automated recording
processing

SUPEPT-315 The system is made robust against selecting the same signal
multiple times when doing automated recording
post-processing.

Apply a Thermocouple
type C sensor,
Perception shows
type B

SUPEPT-316 A thermocouple type C sensor is now shown as such.

Redo an existing
Experiment and load
existing Experiment
data does not include
data

SUPEPT-322 On opening Perception and selecting 'Redo an existing
experiment and load existing experiment data', the data was
not always loaded. This problem is solved.

Recordings got locked
up by Perception

SUPEPT-325 When a recording is finished, it is unlocked and can be
accessed by other software. Sometimes the recording was
not unlocked and this problem is now solved.

Perception crashing
when starting to
record

SUPEPT-326 Sometimes Perception crashed when starting a recording.
This problem is solved.

Multiple mainframe
setup crashing after
10 minutes into
recording

SUPEPT-327 In a high-load multiple mainframe setup, the system crashed
after 10 minutes of recording. This problem is solved.

The static hysteresis
value in the ePower
suite does not adapt
automatically with the
span

SUPEPT-328 Some RTFDB functions allow inputs only in a certain range.
When inside the RTFDB an invalid argument is provided, it is
adjusted and a warning is given by highlighting the affected
formula. When an invalid argument is set from the ePower
suite (like the static hysteresis value) warning are now given
at several places.

Split recordings made
on mainframe are not
complete

SUPEPT-329 With the new split recording functionality, the data in each
recording was not complete. This is solved.

Used channel names
are incomplete shown

SUPEPT-330 In Perception in the ePower suite, in certain situations the
channel name was not completely shown. This is solved.

Allow segments
shorter than 10
seconds in a split
recording

SUPEPT-332 In an earlier release, split recordings were introduced
allowing to, during the recording process, generate several
small subrecordings rather than one single large recording.
The minimum time interval covered by such a subrecording
was 10 seconds but is now reduced to 1 second. Go to File →
Preferences... → Perception → Recordings and, in the
Recording creation box, check 'Split continuous recording
into subrecordings after', and choose the length of each part
of the recording in seconds.
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No MDF4 file when
exporting using
automated processing

SUPEPT-333 The problem of a missing MDF4 file when exporting using
automated processing was solved.

Sluggish behavior
when loading a virtual
workbench

SUPEPT-337 In some case, Perception could react in a sluggish manner
when loading a virtual workbench. This problem is solved.

Perception
diagnostics increased
1GB per day

SUPEPT-342 A problem with a fast growing Perception diagnostics files
was solved.

Usage of ratio is
wrong in rt formulas
for gearbox

SUPEPT-356 In the ePower suite, an RTFDB formula that is instantiated
when using the artificial gearbox components contained an
error which is now solved.

HBK-Public Page 14



7 Deprecated support

The following is no longer supported within Perception:

• GPS2750
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8 Supported Genesis HighSpeed Mainframes

The following Genesis HighSpeed Mainframes are supported:

• GEN2tB
• GEN3t
• GEN4tB
• GEN7tA
• GEN17tA
• GEN3i
• GEN3iA
• GEN7i
• GEN7iA
• GEN7iB
• GEN7tB
• GEN17tB
• BE3200
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9 Supported QuantumX Modules

Note: The support of QuantumX Modules in Perception will stop with future versions of Per-
ception! QuantumX modules can be integrated in systems with tethered mainframes using the
CAN-interface together with a QuantumX MX471C.
The following QuantumX models are supported:

• MX1609KB
• MX1609TB
• MX471B
• MX809B
• CX27B as single network access point only, no setup or control of CX27B

Patents no: 7,868,886
©Hottinger Brüel & Kjaer GmbH. All rights reserved.
All details describe our products in general form only.
They are not to be understood as express warranty and do not constitute any liability whatsoever.

Hottinger Brüel & Kjaer GmbH
Im Tiefen See 45 ∙ 64293 Darmstadt ∙ Germany
Tel. +49 6151 803-0 ∙ Fax: +49 6151 803-9100
E-mail: info@hbkworld.com ∙ www.hbm.com
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